qt4-x11-4.5.2-2.el5.elgis.x86_64.rpm


Advertisement

Description

qt4-x11 - Qt GUI-related libraries

Property Value
Distribution CentOS 5
Repository EL GIS Plus x86_64
Package name qt4-x11
Package version 4.5.2
Package release 2.el5.elgis
Package architecture x86_64
Package type rpm
Installed size 44.88 MB
Download size 16.25 MB
Official Mirror elgis.argeo.org
Qt libraries used for drawing widgets and OpenGL items.

Alternatives

Package Version Architecture Repository
qt4-x11-4.5.2-2.el5.elgis.i386.rpm 4.5.2 i386 EL GIS Plus
qt4-x11-4.5.2-2.el5.elgis.i386.rpm 4.5.2 i386 EL GIS Plus
qt4-x11-4.2.1-0.0.PU_IAS.5.i386.rpm 4.2.1 i386 PUIAS Unsupported
qt4-x11-4.2.1-0.0.PU_IAS.5.x86_64.rpm 4.2.1 x86_64 PUIAS Unsupported
qt4-x11 - - -

Requires

Name Value
libGL.so.1()(64bit) -
libGLU.so.1()(64bit) -
libICE.so.6()(64bit) -
libQt3Support.so.4()(64bit) -
libQtAssistantClient.so.4()(64bit) -
libQtCLucene.so.4()(64bit) -
libQtCore.so.4()(64bit) -
libQtDBus.so.4()(64bit) -
libQtDesigner.so.4()(64bit) -
libQtDesignerComponents.so.4()(64bit) -
libQtGui.so.4()(64bit) -
libQtHelp.so.4()(64bit) -
libQtNetwork.so.4()(64bit) -
libQtOpenGL.so.4()(64bit) -
libQtScript.so.4()(64bit) -
libQtScriptTools.so.4()(64bit) -
libQtSql.so.4()(64bit) -
libQtSvg.so.4()(64bit) -
libQtWebKit.so.4()(64bit) -
libQtXml.so.4()(64bit) -
libSM.so.6()(64bit) -
libX11.so.6()(64bit) -
libXcursor.so.1()(64bit) -
libXext.so.6()(64bit) -
libXfixes.so.3()(64bit) -
libXi.so.6()(64bit) -
libXinerama.so.1()(64bit) -
libXrandr.so.2()(64bit) -
libXrender.so.1()(64bit) -
libc.so.6()(64bit) -
libc.so.6(GLIBC_2.2.5)(64bit) -
libc.so.6(GLIBC_2.4)(64bit) -
libcrypto.so.6()(64bit) -
libdbus-1.so.3()(64bit) -
libdl.so.2()(64bit) -
libdl.so.2(GLIBC_2.2.5)(64bit) -
libfontconfig.so.1()(64bit) -
libfreetype.so.6()(64bit) -
libgcc_s.so.1()(64bit) -
libgcc_s.so.1(GCC_3.0)(64bit) -
libglib-2.0.so.0()(64bit) -
libgmodule-2.0.so.0()(64bit) -
libgobject-2.0.so.0()(64bit) -
libgstaudio-0.10.so.0()(64bit) -
libgstbase-0.10.so.0()(64bit) -
libgstinterfaces-0.10.so.0()(64bit) -
libgstreamer-0.10.so.0()(64bit) -
libgstvideo-0.10.so.0()(64bit) -
libgthread-2.0.so.0()(64bit) -
libjpeg.so.62()(64bit) -
libm.so.6()(64bit) -
libm.so.6(GLIBC_2.2.5)(64bit) -
libmng.so.1()(64bit) -
libphonon.so.4()(64bit) -
libpng12.so.0()(64bit) -
libpng12.so.0(PNG12_0)(64bit) -
libpthread.so.0()(64bit) -
libpthread.so.0(GLIBC_2.2.5)(64bit) -
librt.so.1()(64bit) -
libsqlite3.so.0()(64bit) -
libssl.so.6()(64bit) -
libstdc++.so.6()(64bit) -
libstdc++.so.6(CXXABI_1.3)(64bit) -
libstdc++.so.6(GLIBCXX_3.4)(64bit) -
libtiff.so.3()(64bit) -
libxml2.so.2()(64bit) -
libz.so.1()(64bit) -
qt4 = 4.5.2-2.el5.elgis
rtld(GNU_HASH) -

Provides

Name Value
WebKit-qt = 1.0.0-1
libQt3Support.so.4()(64bit) -
libQtAssistantClient.so.4()(64bit) -
libQtCLucene.so.4()(64bit) -
libQtDesigner.so.4()(64bit) -
libQtDesignerComponents.so.4()(64bit) -
libQtGui.so.4()(64bit) -
libQtHelp.so.4()(64bit) -
libQtOpenGL.so.4()(64bit) -
libQtScriptTools.so.4()(64bit) -
libQtSvg.so.4()(64bit) -
libQtWebKit.so.4()(64bit) -
libarthurplugin.so()(64bit) -
libcontainerextension.so()(64bit) -
libcustomwidgetplugin.so()(64bit) -
libphonon.so.4()(64bit) -
libphonon_gstreamer.so()(64bit) -
libphononwidgets.so()(64bit) -
libqcncodecs.so()(64bit) -
libqgif.so()(64bit) -
libqglgraphicssystem.so()(64bit) -
libqico.so()(64bit) -
libqimsw-multi.so()(64bit) -
libqjpcodecs.so()(64bit) -
libqjpeg.so()(64bit) -
libqkrcodecs.so()(64bit) -
libqmng.so()(64bit) -
libqsvg.so()(64bit) -
libqsvgicon.so()(64bit) -
libqt3supportwidgets.so()(64bit) -
libqtaccessiblecompatwidgets.so()(64bit) -
libqtaccessiblewidgets.so()(64bit) -
libqtiff.so()(64bit) -
libqtscriptdbus.so()(64bit) -
libqtwcodecs.so()(64bit) -
libqwebview.so()(64bit) -
libtaskmenuextension.so()(64bit) -
libworldtimeclockplugin.so()(64bit) -
phonon = 4.3.1-100
qt4-assistant = 4.5.2-2.el5.elgis
qt4-phonon = 4.5.2-2.el5.elgis
qt4-x11 = 4.5.2-2.el5.elgis

Obsoletes

Name Value
WebKit-qt < 1.0.0-1
phonon < 4.3.1-100

Download

Type URL
Binary Package qt4-x11-4.5.2-2.el5.elgis.x86_64.rpm
Source Package qt4-4.5.2-2.el5.elgis.src.rpm

Install Howto

  1. Download latest elgis-release rpm from
    http://elgis.argeo.org/repos/5/
  2. Install elgis-release rpm:
    # rpm -Uvh elgis-release*rpm
  3. Install qt4-x11 rpm package:
    # yum --enablerepo=elgis-plus install qt4-x11

Files

Path
/etc/rpm/macros.qt4
/usr/bin/assistant-qt4
/usr/bin/assistant_adp
/usr/bin/qdbusviewer
/usr/bin/qtconfig-qt4
/usr/lib64/libQt3Support.so.4
/usr/lib64/libQt3Support.so.4.5
/usr/lib64/libQt3Support.so.4.5.2
/usr/lib64/libQtAssistantClient.so.4
/usr/lib64/libQtAssistantClient.so.4.5
/usr/lib64/libQtAssistantClient.so.4.5.2
/usr/lib64/libQtCLucene.so.4
/usr/lib64/libQtCLucene.so.4.5
/usr/lib64/libQtCLucene.so.4.5.2
/usr/lib64/libQtDesigner.so.4
/usr/lib64/libQtDesigner.so.4.5
/usr/lib64/libQtDesigner.so.4.5.2
/usr/lib64/libQtDesignerComponents.so.4
/usr/lib64/libQtDesignerComponents.so.4.5
/usr/lib64/libQtDesignerComponents.so.4.5.2
/usr/lib64/libQtGui.so.4
/usr/lib64/libQtGui.so.4.5
/usr/lib64/libQtGui.so.4.5.2
/usr/lib64/libQtHelp.so.4
/usr/lib64/libQtHelp.so.4.5
/usr/lib64/libQtHelp.so.4.5.2
/usr/lib64/libQtOpenGL.so.4
/usr/lib64/libQtOpenGL.so.4.5
/usr/lib64/libQtOpenGL.so.4.5.2
/usr/lib64/libQtScriptTools.so.4
/usr/lib64/libQtScriptTools.so.4.5
/usr/lib64/libQtScriptTools.so.4.5.2
/usr/lib64/libQtSvg.so.4
/usr/lib64/libQtSvg.so.4.5
/usr/lib64/libQtSvg.so.4.5.2
/usr/lib64/libQtWebKit.so.4
/usr/lib64/libQtWebKit.so.4.5
/usr/lib64/libQtWebKit.so.4.5.2
/usr/lib64/libphonon.so.4
/usr/lib64/libphonon.so.4.3
/usr/lib64/libphonon.so.4.3.1
/usr/lib64/qt4/bin/assistant
/usr/lib64/qt4/bin/assistant-qt4
/usr/lib64/qt4/bin/assistant_adp
/usr/lib64/qt4/bin/qdbusviewer
/usr/lib64/qt4/bin/qtconfig
/usr/lib64/qt4/bin/qtconfig-qt4
/usr/lib64/qt4/plugins/accessible/libqtaccessiblecompatwidgets.so
/usr/lib64/qt4/plugins/accessible/libqtaccessiblewidgets.so
/usr/lib64/qt4/plugins/codecs/libqcncodecs.so
/usr/lib64/qt4/plugins/codecs/libqjpcodecs.so
/usr/lib64/qt4/plugins/codecs/libqkrcodecs.so
/usr/lib64/qt4/plugins/codecs/libqtwcodecs.so
/usr/lib64/qt4/plugins/designer/libarthurplugin.so
/usr/lib64/qt4/plugins/designer/libcontainerextension.so
/usr/lib64/qt4/plugins/designer/libcustomwidgetplugin.so
/usr/lib64/qt4/plugins/designer/libphononwidgets.so
/usr/lib64/qt4/plugins/designer/libqt3supportwidgets.so
/usr/lib64/qt4/plugins/designer/libqwebview.so
/usr/lib64/qt4/plugins/designer/libtaskmenuextension.so
/usr/lib64/qt4/plugins/designer/libworldtimeclockplugin.so
/usr/lib64/qt4/plugins/graphicssystems/libqglgraphicssystem.so
/usr/lib64/qt4/plugins/iconengines/libqsvgicon.so
/usr/lib64/qt4/plugins/imageformats/libqgif.so
/usr/lib64/qt4/plugins/imageformats/libqico.so
/usr/lib64/qt4/plugins/imageformats/libqjpeg.so
/usr/lib64/qt4/plugins/imageformats/libqmng.so
/usr/lib64/qt4/plugins/imageformats/libqsvg.so
/usr/lib64/qt4/plugins/imageformats/libqtiff.so
/usr/lib64/qt4/plugins/inputmethods/libqimsw-multi.so
/usr/lib64/qt4/plugins/phonon_backend/libphonon_gstreamer.so
/usr/lib64/qt4/plugins/script/libqtscriptdbus.so
/usr/lib64/qt4/plugins/styles/
/usr/share/applications/qt4-qtconfig.desktop
/usr/share/icons/hicolor/128x128/apps/qt4-logo.png
/usr/share/icons/hicolor/48x48/apps/qt4-logo.png

Changelog

See qt4-4.5.2-2.el5.elgis.x86_64.rpm changelog.

See Also

Package Description
sip-4.8.2-2.el5.elgis.i386.rpm SIP - Python/C++ Bindings Generator
sip-devel-4.8.2-2.el5.elgis.i386.rpm Files needed to generate Python bindings for any C++ class library
sqlite-3.5.9-2.el5.elgis.i386.rpm Library that implements an embeddable SQL database engine
sqlite-3.5.9-2.el5.elgis.x86_64.rpm Library that implements an embeddable SQL database engine
sqlite-devel-3.5.9-2.el5.elgis.i386.rpm Development tools for the sqlite3 embeddable SQL database engine
sqlite-devel-3.5.9-2.el5.elgis.x86_64.rpm Development tools for the sqlite3 embeddable SQL database engine
sqlite-tcl-3.5.9-2.el5.elgis.i386.rpm Tcl module for the sqlite3 embeddable SQL database engine
sqlite-tcl-3.5.9-2.el5.elgis.x86_64.rpm Tcl module for the sqlite3 embeddable SQL database engine
Advertisement
Advertisement