qt4-4.5.2-2.el5.elgis.i386.rpm


Advertisement

Description

qt4 - Qt toolkit

Property Value
Distribution CentOS 5
Repository EL GIS Plus x86_64
Package name qt4
Package version 4.5.2
Package release 2.el5.elgis
Package architecture i386
Package type rpm
Installed size 11.12 MB
Download size 3.87 MB
Official Mirror elgis.argeo.org
Qt is a software toolkit for developing applications.
This package contains base tools, like string, xml, and network
handling.

Alternatives

Package Version Architecture Repository
qt4-4.5.2-2.el5.elgis.i386.rpm 4.5.2 i386 EL GIS Plus
qt4-4.5.2-2.el5.elgis.x86_64.rpm 4.5.2 x86_64 EL GIS Plus
qt4-4.2.1-1.el5_7.1.i386.rpm 4.2.1 i386 CentOS
qt4-4.2.1-1.el5_7.1.x86_64.rpm 4.2.1 x86_64 CentOS
qt4-4.2.1-1.el5_7.1.i386.rpm 4.2.1 i386 CentOS
qt4 - - -

Requires

Name Value
/sbin/ldconfig -
config(qt4) = 4.5.2-2.el5.elgis
libQtCore.so.4 -
libQtDBus.so.4 -
libQtNetwork.so.4 -
libQtScript.so.4 -
libQtSql.so.4 -
libQtTest.so.4 -
libQtXml.so.4 -
libQtXmlPatterns.so.4 -
libc.so.6 -
libc.so.6(GLIBC_2.0) -
libc.so.6(GLIBC_2.1) -
libc.so.6(GLIBC_2.1.2) -
libc.so.6(GLIBC_2.1.3) -
libc.so.6(GLIBC_2.2) -
libc.so.6(GLIBC_2.3) -
libc.so.6(GLIBC_2.4) -
libcrypto.so.6 -
libdbus-1.so.3 -
libdl.so.2 -
libdl.so.2(GLIBC_2.0) -
libdl.so.2(GLIBC_2.1) -
libgcc_s.so.1 -
libgcc_s.so.1(GCC_3.0) -
libgcc_s.so.1(GLIBC_2.0) -
libglib-2.0.so.0 -
libgthread-2.0.so.0 -
libm.so.6 -
libm.so.6(GLIBC_2.0) -
libm.so.6(GLIBC_2.1) -
libm.so.6(GLIBC_2.2) -
libpthread.so.0 -
libpthread.so.0(GLIBC_2.0) -
libpthread.so.0(GLIBC_2.1) -
libpthread.so.0(GLIBC_2.2) -
libpthread.so.0(GLIBC_2.3.2) -
librt.so.1 -
librt.so.1(GLIBC_2.2) -
libsqlite3.so.0 -
libssl.so.6 -
libstdc++.so.6 -
libstdc++.so.6(CXXABI_1.3) -
libstdc++.so.6(GLIBCXX_3.4) -
libz.so.1 -
rtld(GNU_HASH) -

Provides

Name Value
config(qt4) = 4.5.2-2.el5.elgis
libQtCore.so.4 -
libQtDBus.so.4 -
libQtNetwork.so.4 -
libQtScript.so.4 -
libQtSql.so.4 -
libQtTest.so.4 -
libQtXml.so.4 -
libQtXmlPatterns.so.4 -
libqsqlite.so -
qgtkstyle = 0.1-1
qt-copy = 20090626
qt4 = 4.5.2-2.el5.elgis
qt4-config = 4.5.2-2.el5.elgis
qt4-copy = 20090626
qt4-sqlite = 4.5.2-2.el5.elgis

Obsoletes

Name Value
qgtkstyle < 0.1
qt4-config < 4.5.0
qt4-sqlite < 4.5.0

Download

Type URL
Binary Package qt4-4.5.2-2.el5.elgis.i386.rpm
Source Package qt4-4.5.2-2.el5.elgis.src.rpm

Install Howto

  1. Download latest elgis-release rpm from
    http://elgis.argeo.org/repos/5/
  2. Install elgis-release rpm:
    # rpm -Uvh elgis-release*rpm
  3. Install qt4 rpm package:
    # yum --enablerepo=elgis-plus install qt4

Files

Path
/etc/Trolltech.conf
/usr/bin/qdbus
/usr/lib/libQtCore.so.4
/usr/lib/libQtCore.so.4.5
/usr/lib/libQtCore.so.4.5.2
/usr/lib/libQtDBus.so.4
/usr/lib/libQtDBus.so.4.5
/usr/lib/libQtDBus.so.4.5.2
/usr/lib/libQtNetwork.so.4
/usr/lib/libQtNetwork.so.4.5
/usr/lib/libQtNetwork.so.4.5.2
/usr/lib/libQtScript.so.4
/usr/lib/libQtScript.so.4.5
/usr/lib/libQtScript.so.4.5.2
/usr/lib/libQtSql.so.4
/usr/lib/libQtSql.so.4.5
/usr/lib/libQtSql.so.4.5.2
/usr/lib/libQtTest.so.4
/usr/lib/libQtTest.so.4.5
/usr/lib/libQtTest.so.4.5.2
/usr/lib/libQtXml.so.4
/usr/lib/libQtXml.so.4.5
/usr/lib/libQtXml.so.4.5.2
/usr/lib/libQtXmlPatterns.so.4
/usr/lib/libQtXmlPatterns.so.4.5
/usr/lib/libQtXmlPatterns.so.4.5.2
/usr/lib/qt4/
/usr/lib/qt4/bin/qdbus
/usr/lib/qt4/phrasebooks/danish.qph
/usr/lib/qt4/phrasebooks/dutch.qph
/usr/lib/qt4/phrasebooks/finnish.qph
/usr/lib/qt4/phrasebooks/french.qph
/usr/lib/qt4/phrasebooks/german.qph
/usr/lib/qt4/phrasebooks/italian.qph
/usr/lib/qt4/phrasebooks/japanese.qph
/usr/lib/qt4/phrasebooks/norwegian.qph
/usr/lib/qt4/phrasebooks/polish.qph
/usr/lib/qt4/phrasebooks/russian.qph
/usr/lib/qt4/phrasebooks/spanish.qph
/usr/lib/qt4/phrasebooks/swedish.qph
/usr/lib/qt4/plugins/
/usr/lib/qt4/plugins/sqldrivers/libqsqlite.so
/usr/share/doc/qt4-4.5.2/LGPL_EXCEPTION.txt
/usr/share/doc/qt4-4.5.2/LICENSE.GPL3
/usr/share/doc/qt4-4.5.2/LICENSE.LGPL
/usr/share/doc/qt4-4.5.2/README
/usr/share/doc/qt4-4.5.2/README.qt-copy
/usr/share/qt4/
/usr/share/qt4/translations/assistant_adp_de.qm
/usr/share/qt4/translations/assistant_adp_ja.qm
/usr/share/qt4/translations/assistant_adp_pl.qm
/usr/share/qt4/translations/assistant_adp_untranslated.qm
/usr/share/qt4/translations/assistant_adp_zh_CN.qm
/usr/share/qt4/translations/assistant_adp_zh_TW.qm
/usr/share/qt4/translations/assistant_de.qm
/usr/share/qt4/translations/assistant_ja.qm
/usr/share/qt4/translations/assistant_pl.qm
/usr/share/qt4/translations/assistant_untranslated.qm
/usr/share/qt4/translations/assistant_zh_CN.qm
/usr/share/qt4/translations/assistant_zh_TW.qm
/usr/share/qt4/translations/designer_de.qm
/usr/share/qt4/translations/designer_ja.qm
/usr/share/qt4/translations/designer_pl.qm
/usr/share/qt4/translations/designer_untranslated.qm
/usr/share/qt4/translations/designer_zh_CN.qm
/usr/share/qt4/translations/designer_zh_TW.qm
/usr/share/qt4/translations/linguist_de.qm
/usr/share/qt4/translations/linguist_fr.qm
/usr/share/qt4/translations/linguist_ja.qm
/usr/share/qt4/translations/linguist_pl.qm
/usr/share/qt4/translations/linguist_untranslated.qm
/usr/share/qt4/translations/linguist_zh_CN.qm
/usr/share/qt4/translations/linguist_zh_TW.qm
/usr/share/qt4/translations/qt_ar.qm
/usr/share/qt4/translations/qt_de.qm
/usr/share/qt4/translations/qt_es.qm
/usr/share/qt4/translations/qt_fr.qm
/usr/share/qt4/translations/qt_help_de.qm
/usr/share/qt4/translations/qt_help_ja.qm
/usr/share/qt4/translations/qt_help_pl.qm
/usr/share/qt4/translations/qt_help_untranslated.qm
/usr/share/qt4/translations/qt_help_zh_CN.qm
/usr/share/qt4/translations/qt_help_zh_TW.qm
/usr/share/qt4/translations/qt_iw.qm
/usr/share/qt4/translations/qt_ja_JP.qm
/usr/share/qt4/translations/qt_pl.qm
/usr/share/qt4/translations/qt_pt.qm
/usr/share/qt4/translations/qt_ru.qm
/usr/share/qt4/translations/qt_sk.qm
/usr/share/qt4/translations/qt_sv.qm
/usr/share/qt4/translations/qt_uk.qm
/usr/share/qt4/translations/qt_untranslated.qm
/usr/share/qt4/translations/qt_zh_CN.qm
/usr/share/qt4/translations/qt_zh_TW.qm
/usr/share/qt4/translations/qtconfig_pl.qm
/usr/share/qt4/translations/qtconfig_untranslated.qm
/usr/share/qt4/translations/qtconfig_zh_CN.qm
/usr/share/qt4/translations/qtconfig_zh_TW.qm
/usr/share/qt4/translations/qvfb_pl.qm
/usr/share/qt4/translations/qvfb_untranslated.qm
/usr/share/qt4/translations/qvfb_zh_CN.qm
/usr/share/qt4/translations/qvfb_zh_TW.qm

Changelog

2010-01-06 - Mathieu Baudier <mbaudieràargeo.org> - 4.5.2-2.el5.argeo
- Integrate Phonon backend
2009-07-02 - Than Ngo <than@redhat.com> - 4.5.2-1
- 4.5.2
2009-05-30 - Rex Dieter <rdieter@fedoraproject.org> - 4.5.1-13
- -doc: Obsoletes: qt-doc < 1:4.5.1-4 (workaround bug #502401)
2009-05-23 - Rex Dieter <rdieter@fedoraproject.org> - 4.5.1-12
- +phonon_internal macro to toggle packaging of qt's phonon (default off)
2009-05-22 - Rex Dieter <rdieter@fedoraproject.org> - 4.5.1-11
- qt-copy-patches-20090522
2009-05-20 - Rex Dieter <rdieter@fedoraproject.org> - 4.5.1-10.2
- full (non-bootstrap) build
2009-05-20 - Rex Dieter <rdieter@fedoraproject.org> - 4.5.1-10.1
- allow for minimal bootstrap build (*cough* arm *cough*)
2009-05-06 - Rex Dieter <rdieter@fedoraproject.org> - 4.5.1-10
- improved kde4_plugins patch, skip expensive/unneeded canonicalPath
2009-05-06 - Rex Dieter <rdieter@fedoraproject.org> - 4.5.1-9
- include kde4 plugin path by default (#498809)
2009-05-04 - Rex Dieter <rdieter@fedoraproject.org> - 4.5.1-8
- fix invalid assumptions about mysql_config --libs (bug #440673)
- fix %files breakage from 4.5.1-5

See Also

Package Description
qt4-demos-4.5.2-2.el5.elgis.i386.rpm Demonstration applications for qt4
qt4-demos-4.5.2-2.el5.elgis.x86_64.rpm Demonstration applications for qt4
qt4-devel-4.5.2-2.el5.elgis.i386.rpm Development files for the Qt toolkit
qt4-devel-4.5.2-2.el5.elgis.x86_64.rpm Development files for the Qt toolkit
qt4-doc-4.5.2-2.el5.elgis.i386.rpm API documentation for qt4
qt4-doc-4.5.2-2.el5.elgis.x86_64.rpm API documentation for qt4
qt4-examples-4.5.2-2.el5.elgis.i386.rpm Programming examples for qt4
qt4-examples-4.5.2-2.el5.elgis.x86_64.rpm Programming examples for qt4
qt4-mysql-4.5.2-2.el5.elgis.i386.rpm MySQL driver for Qt's SQL classes
qt4-mysql-4.5.2-2.el5.elgis.x86_64.rpm MySQL driver for Qt's SQL classes
qt4-odbc-4.5.2-2.el5.elgis.i386.rpm ODBC driver for Qt's SQL classes
qt4-odbc-4.5.2-2.el5.elgis.x86_64.rpm ODBC driver for Qt's SQL classes
qt4-postgresql-4.5.2-2.el5.elgis.i386.rpm PostgreSQL driver for Qt's SQL classes
qt4-postgresql-4.5.2-2.el5.elgis.x86_64.rpm PostgreSQL driver for Qt's SQL classes
qt4-x11-4.5.2-2.el5.elgis.i386.rpm Qt GUI-related libraries
Advertisement
Advertisement