nss-3.19.1-2.el5_11.i386.rpm


Advertisement

Description

nss - Network Security Services

Property Value
Distribution CentOS 5
Repository CentOS Updates x86_64
Package name nss
Package version 3.19.1
Package release 2.el5_11
Package architecture i386
Package type rpm
Installed size 3.06 MB
Download size 1.26 MB
Official Mirror vault.centos.org
Network Security Services (NSS) is a set of libraries designed to
support cross-platform development of security-enabled client and
server applications. Applications built with NSS can support SSL v2
and v3, TLS, PKCS #5, PKCS #7, PKCS #11, PKCS #12, S/MIME, X.509
v3 certificates, and other security standards.

Alternatives

Package Version Architecture Repository
nss-3.21.3-2.el5_11.i386.rpm 3.21.3 i386 CentOS Updates
nss-3.21.3-2.el5_11.i386.rpm 3.21.3 i386 CentOS Updates
nss-3.21.3-2.el5_11.x86_64.rpm 3.21.3 x86_64 CentOS Updates
nss-3.21.0-6.el5_11.i386.rpm 3.21.0 i386 CentOS Updates
nss-3.21.0-6.el5_11.i386.rpm 3.21.0 i386 CentOS Updates
nss-3.21.0-6.el5_11.x86_64.rpm 3.21.0 x86_64 CentOS Updates
nss-3.19.1-4.el5_11.i386.rpm 3.19.1 i386 CentOS Updates
nss-3.19.1-4.el5_11.i386.rpm 3.19.1 i386 CentOS Updates
nss-3.19.1-4.el5_11.x86_64.rpm 3.19.1 x86_64 CentOS Updates
nss-3.19.1-2.el5_11.i386.rpm 3.19.1 i386 CentOS Updates
nss-3.19.1-2.el5_11.x86_64.rpm 3.19.1 x86_64 CentOS Updates
nss-3.19.1-1.el5_11.i386.rpm 3.19.1 i386 CentOS Updates
nss-3.19.1-1.el5_11.i386.rpm 3.19.1 i386 CentOS Updates
nss-3.19.1-1.el5_11.x86_64.rpm 3.19.1 x86_64 CentOS Updates
nss-3.18.0-6.el5_11.i386.rpm 3.18.0 i386 CentOS Updates
nss-3.18.0-6.el5_11.i386.rpm 3.18.0 i386 CentOS Updates
nss-3.18.0-6.el5_11.x86_64.rpm 3.18.0 x86_64 CentOS Updates
nss-3.16.2.3-1.el5_11.i386.rpm 3.16.2.3 i386 CentOS Updates
nss-3.16.2.3-1.el5_11.i386.rpm 3.16.2.3 i386 CentOS Updates
nss-3.16.2.3-1.el5_11.x86_64.rpm 3.16.2.3 x86_64 CentOS Updates
nss-3.16.1-4.el5_11.i386.rpm 3.16.1 i386 CentOS Updates
nss-3.16.1-4.el5_11.i386.rpm 3.16.1 i386 CentOS Updates
nss-3.16.1-4.el5_11.x86_64.rpm 3.16.1 x86_64 CentOS Updates
nss-3.16.1-2.el5.i386.rpm 3.16.1 i386 CentOS
nss-3.16.1-2.el5.x86_64.rpm 3.16.1 x86_64 CentOS
nss-3.16.1-2.el5.i386.rpm 3.16.1 i386 CentOS
nss - - -

Requires

Name Value
/sbin/ldconfig -
config(nss) = 3.19.1-2.el5_11
libc.so.6 -
libc.so.6(GLIBC_2.0) -
libc.so.6(GLIBC_2.1) -
libc.so.6(GLIBC_2.1.3) -
libc.so.6(GLIBC_2.3) -
libc.so.6(GLIBC_2.3.2) -
libc.so.6(GLIBC_2.3.4) -
libc.so.6(GLIBC_2.4) -
libdl.so.2 -
libdl.so.2(GLIBC_2.0) -
libdl.so.2(GLIBC_2.1) -
libnspr4.so -
libnss3.so -
libnss3.so(NSS_3.10) -
libnss3.so(NSS_3.11) -
libnss3.so(NSS_3.11.1) -
libnss3.so(NSS_3.11.2) -
libnss3.so(NSS_3.12) -
libnss3.so(NSS_3.12.6) -
libnss3.so(NSS_3.14) -
libnss3.so(NSS_3.14.3) -
libnss3.so(NSS_3.15) -
libnss3.so(NSS_3.19.1) -
libnss3.so(NSS_3.2) -
libnss3.so(NSS_3.3) -
libnss3.so(NSS_3.3.1) -
libnss3.so(NSS_3.4) -
libnss3.so(NSS_3.6) -
libnss3.so(NSS_3.7) -
libnss3.so(NSS_3.8) -
libnss3.so(NSS_3.9) -
libnssutil3.so -
libnssutil3.so(NSSUTIL_3.12) -
libnssutil3.so(NSSUTIL_3.12.3) -
libnssutil3.so(NSSUTIL_3.12.5) -
libnssutil3.so(NSSUTIL_3.13) -
libnssutil3.so(NSSUTIL_3.14) -
libnssutil3.so(NSSUTIL_3.15) -
libnssutil3.so(NSSUTIL_3.17.1) -
libplc4.so -
libplds4.so -
libpthread.so.0 -
libpthread.so.0(GLIBC_2.0) -
libsqlite3.so.0 -
libz.so.1 -
nspr >= 4.10.8-2
rtld(GNU_HASH) -

Provides

Name Value
config(nss) = 3.19.1-2.el5_11
libfreebl3.so -
libfreebl3.so(NSSRAWHASH_3.12.3) -
libfreebl3.so(NSSprivate_3.11) -
libnss3.so -
libnss3.so(NSS_3.10) -
libnss3.so(NSS_3.10.2) -
libnss3.so(NSS_3.11) -
libnss3.so(NSS_3.11.1) -
libnss3.so(NSS_3.11.2) -
libnss3.so(NSS_3.11.7) -
libnss3.so(NSS_3.11.9) -
libnss3.so(NSS_3.12) -
libnss3.so(NSS_3.12.1) -
libnss3.so(NSS_3.12.10) -
libnss3.so(NSS_3.12.3) -
libnss3.so(NSS_3.12.4) -
libnss3.so(NSS_3.12.5) -
libnss3.so(NSS_3.12.6) -
libnss3.so(NSS_3.12.7) -
libnss3.so(NSS_3.12.9) -
libnss3.so(NSS_3.13) -
libnss3.so(NSS_3.13.2) -
libnss3.so(NSS_3.14) -
libnss3.so(NSS_3.14.1) -
libnss3.so(NSS_3.14.3) -
libnss3.so(NSS_3.15) -
libnss3.so(NSS_3.15.4) -
libnss3.so(NSS_3.16.1) -
libnss3.so(NSS_3.16.2) -
libnss3.so(NSS_3.18) -
libnss3.so(NSS_3.19) -
libnss3.so(NSS_3.19.1) -
libnss3.so(NSS_3.2) -
libnss3.so(NSS_3.2.1) -
libnss3.so(NSS_3.3) -
libnss3.so(NSS_3.3.1) -
libnss3.so(NSS_3.4) -
libnss3.so(NSS_3.5) -
libnss3.so(NSS_3.6) -
libnss3.so(NSS_3.7) -
libnss3.so(NSS_3.7.1) -
libnss3.so(NSS_3.8) -
libnss3.so(NSS_3.9) -
libnss3.so(NSS_3.9.2) -
libnss3.so(NSS_3.9.3) -
libnssckbi.so -
libnssckbi.so(NSS_3.1) -
libnssdbm3.so -
libnssdbm3.so(NSSDBM_3.12) -
libnssutil3.so -
libnssutil3.so(NSSUTIL_3.12) -
libnssutil3.so(NSSUTIL_3.12.3) -
libnssutil3.so(NSSUTIL_3.12.5) -
libnssutil3.so(NSSUTIL_3.12.7) -
libnssutil3.so(NSSUTIL_3.13) -
libnssutil3.so(NSSUTIL_3.14) -
libnssutil3.so(NSSUTIL_3.15) -
libnssutil3.so(NSSUTIL_3.17.1) -
libsmime3.so -
libsmime3.so(NSS_3.10) -
libsmime3.so(NSS_3.12.10) -
libsmime3.so(NSS_3.12.2) -
libsmime3.so(NSS_3.13) -
libsmime3.so(NSS_3.15) -
libsmime3.so(NSS_3.16) -
libsmime3.so(NSS_3.18) -
libsmime3.so(NSS_3.2) -
libsmime3.so(NSS_3.2.1) -
libsmime3.so(NSS_3.3) -
libsmime3.so(NSS_3.4) -
libsmime3.so(NSS_3.4.1) -
libsmime3.so(NSS_3.6) -
libsmime3.so(NSS_3.7) -
libsmime3.so(NSS_3.7.2) -
libsmime3.so(NSS_3.8) -
libsmime3.so(NSS_3.9) -
libsmime3.so(NSS_3.9.3) -
libsoftokn3.so -
libsoftokn3.so(NSS_3.4) -
libssl3.so -
libssl3.so(NSS_3.11.4) -
libssl3.so(NSS_3.11.8) -
libssl3.so(NSS_3.12.10) -
libssl3.so(NSS_3.12.6) -
libssl3.so(NSS_3.13) -
libssl3.so(NSS_3.13.2) -
libssl3.so(NSS_3.14) -
libssl3.so(NSS_3.15) -
libssl3.so(NSS_3.15.4) -
libssl3.so(NSS_3.2) -
libssl3.so(NSS_3.2.1) -
libssl3.so(NSS_3.4) -
libssl3.so(NSS_3.7.4) -
mozilla-nss -
nss = 3.19.1-2.el5_11

Conflicts

Name Value
prelink <= 0.3.9-2

Obsoletes

Name Value
mozilla-nss -

Download

Type URL
Binary Package nss-3.19.1-2.el5_11.i386.rpm
Source Package nss-3.19.1-2.el5_11.src.rpm

Install Howto

Install the nss rpm package:

# yum install nss

Files

Path
/etc/pki/nssdb/cert8.db
/etc/pki/nssdb/key3.db
/etc/pki/nssdb/secmod.db
/usr/lib/libfreebl3.chk
/usr/lib/libfreebl3.so
/usr/lib/libnss3.so
/usr/lib/libnssckbi.so
/usr/lib/libnssdbm3.chk
/usr/lib/libnssdbm3.so
/usr/lib/libnssutil3.so
/usr/lib/libsmime3.so
/usr/lib/libsoftokn3.chk
/usr/lib/libsoftokn3.so
/usr/lib/libssl3.so
/usr/lib/nss/unsupported-tools/shlibsign

Changelog

2015-10-19 - Elio Maldonado <emaldona@redhat.com> - 3.19.1-2
- Resolves: Bug 1269354 - CVE-2015-7182 CVE-2015-7181
2015-07-29 - Elio Maldonado <emaldona@redhat.com> - 3.19.1-1
- Rebase nss to 3.19.1
- Pick up upstream fix for client auth. regression caused by 3.19.1
- Revert upstream change to minimum key sizes
- Remove patches that rendered obsolote by the rebase
- Update existing patches on account of the rebase
2015-07-28 - Elio Maldonado <emaldona@redhat.com> - 3.18.0-7
- Pick up upstream patch from nss-3.19.1
- Resolves: Bug 1236954 - CVE-2015-2730 NSS: ECDSA signature validation fails to handle some signatures correctly (MFSA 2015-64)
- Resolves: Bug 1236967 - CVE-2015-2721 NSS: incorrectly permited skipping of ServerKeyExchange (MFSA 2015-71)
2015-04-28 - Kai Engert <kaie@redhat.com> - 3.18.0-6
- On RHEL 6.x keep the TLS version defaults unchanged.
- Update to CKBI 2.4 from NSS 3.18.1 (the only change in NSS 3.18.1)
2015-04-18 - Elio Maldonado <emaldona@redhat.com> - 3.18.0-5
- Copy PayPalICA.cert and PayPalRootCA.cert to nss/tests/libpkix/certs
- Resolves: Bug 1200905 - Rebase nss to 3.18 for Firefox 38 ESR [RHEL-5.11]
2015-04-18 - Elio Maldonado <emaldona@redhat.com> - 3.18.0-4
- Update and reeneable nss-646045.patch on account of the rebase
- Enable additional ssl test cycles and document why some aren't enabled
- Resolves: Bug 1200905 - Rebase nss to 3.18 for Firefox 38 ESR [RHEL-5.11]
2015-04-13 - Elio Maldonado <emaldona@redhat.com> - 3.18.0-3
- Fix shell syntax error on nss/tests/all.sh
- Resolves: Bug 1200905 - Rebase nss to 3.18 for Firefox 38 ESR [RHEL-5.11]
2015-04-10 - Elio Maldonado <emaldona@redhat.com> - 3.18.0-2
- Replace expired PayPal test certificate that breaks the build
- Resolves: Bug 1200905 - Rebase nss to 3.18 for Firefox 38 ESR [RHEL-5.11]
2015-03-27 - Elio Maldonado <emaldona@redhat.com> - 3.18.0-1
- Resolves: Bug 1200905 - Rebase nss to 3.18 for Firefox 38 ESR [RHEL-5.11]
2014-11-13 - Elio Maldonado <emaldona@redhat.com> - 3.16.1-5
- Resolves: Bug 1158159 - Upgrade to NSS 3.16.2.3 for Firefox 31.3

See Also

Package Description
nss-devel-3.16.1-4.el5_11.i386.rpm Development libraries for Network Security Services
nss-devel-3.16.1-4.el5_11.x86_64.rpm Development libraries for Network Security Services
nss-devel-3.16.2.3-1.el5_11.i386.rpm Development libraries for Network Security Services
nss-devel-3.16.2.3-1.el5_11.x86_64.rpm Development libraries for Network Security Services
nss-devel-3.18.0-6.el5_11.i386.rpm Development libraries for Network Security Services
nss-devel-3.18.0-6.el5_11.x86_64.rpm Development libraries for Network Security Services
nss-devel-3.19.1-1.el5_11.i386.rpm Development libraries for Network Security Services
nss-devel-3.19.1-1.el5_11.x86_64.rpm Development libraries for Network Security Services
nss-devel-3.19.1-2.el5_11.i386.rpm Development libraries for Network Security Services
nss-devel-3.19.1-2.el5_11.x86_64.rpm Development libraries for Network Security Services
nss-devel-3.19.1-4.el5_11.i386.rpm Development libraries for Network Security Services
nss-devel-3.19.1-4.el5_11.x86_64.rpm Development libraries for Network Security Services
nss-devel-3.21.0-6.el5_11.i386.rpm Development libraries for Network Security Services
nss-devel-3.21.0-6.el5_11.x86_64.rpm Development libraries for Network Security Services
nss-devel-3.21.3-2.el5_11.i386.rpm Development libraries for Network Security Services
Advertisement
Advertisement