libbsd-0.6.0-1.el5.art.x86_64.rpm


Advertisement

Description

libbsd - Library providing BSD-compatible functions for portability

Property Value
Distribution CentOS 5
Repository Atomic x86_64
Package name libbsd
Package version 0.6.0
Package release 1.el5.art
Package architecture x86_64
Package type rpm
Installed size 185.77 KB
Download size 65.06 KB
Official Mirror www6.atomicorp.com
libbsd provides useful functions commonly found on BSD systems, and
lacking on others like GNU systems, thus making it easier to port
projects with strong BSD origins, without needing to embed the same
code over and over again on each project.

Alternatives

Package Version Architecture Repository
libbsd-0.8.3-2.el5.i386.rpm 0.8.3 i386 EPEL Testing
libbsd-0.8.3-2.el5.i386.rpm 0.8.3 i386 EPEL Testing
libbsd-0.8.3-2.el5.x86_64.rpm 0.8.3 x86_64 EPEL Testing
libbsd-0.6.0-1.el5.art.i386.rpm 0.6.0 i386 Atomic
libbsd-0.6.0-1.el5.i386.rpm 0.6.0 i386 EPEL
libbsd-0.6.0-1.el5.i386.rpm 0.6.0 i386 EPEL
libbsd-0.6.0-1.el5.x86_64.rpm 0.6.0 x86_64 EPEL
libbsd - - -

Requires

Name Value
/sbin/ldconfig -
libc.so.6(GLIBC_2.4)(64bit) -
rtld(GNU_HASH) -

Provides

Name Value
libbsd = 0.6.0-1.el5.art
libbsd.so.0()(64bit) -
libbsd.so.0(LIBBSD_0.0)(64bit) -
libbsd.so.0(LIBBSD_0.1)(64bit) -
libbsd.so.0(LIBBSD_0.2)(64bit) -
libbsd.so.0(LIBBSD_0.3)(64bit) -
libbsd.so.0(LIBBSD_0.4)(64bit) -
libbsd.so.0(LIBBSD_0.5)(64bit) -
libbsd.so.0(LIBBSD_0.6)(64bit) -

Download

Type URL
Binary Package libbsd-0.6.0-1.el5.art.x86_64.rpm
Source Package libbsd-0.6.0-1.el5.art.src.rpm

Install Howto

  1. Download latest atomic-release rpm from
    http://www6.atomicorp.com/channels/atomic/centos/5/x86_64/RPMS/
  2. Install atomic-release rpm:
    # rpm -Uvh atomic-release*rpm
  3. Install libbsd rpm package:
    # yum install libbsd

Files

Path
/usr/lib64/libbsd.so.0
/usr/lib64/libbsd.so.0.6.0
/usr/share/doc/libbsd-0.6.0/COPYING
/usr/share/doc/libbsd-0.6.0/ChangeLog
/usr/share/doc/libbsd-0.6.0/README
/usr/share/doc/libbsd-0.6.0/TODO

Changelog

2013-07-14 - Eric Smith <brouhaha@fedoraproject.org> - 0.6.0-1
- Update to latest upstream release. Remove patch 0.
- Added ctor-static subpackage.
2013-07-07 - Eric Smith <brouhaha@fedoraproject.org> - 0.5.2-3
- Still having problems with setproctitle(), bug #981799, upstream
freedesktop.org bug #66679. Added patch to noop out setproctitle().
2013-06-11 - Eric Smith <brouhaha@fedoraproject.org> - 0.5.2-2
- Added check section.
- Add BuildRoot for EL5.

See Also

Package Description
libbsd-ctor-static-0.6.0-1.el5.art.x86_64.rpm Development files for libbsd
libbsd-devel-0.6.0-1.el5.art.x86_64.rpm Development files for libbsd
libedit-3.0-2.20090923cvs.el5.art.i386.rpm The NetBSD Editline library
libedit-3.0-2.20090923cvs.el5.art.x86_64.rpm The NetBSD Editline library
libedit-devel-3.0-2.20090923cvs.el5.art.i386.rpm Development files for libedit
libedit-devel-3.0-2.20090923cvs.el5.art.x86_64.rpm Development files for libedit
libicu42-4.2.1-2.el5.art.x86_64.rpm International Components for Unicode - libraries
libicu42-devel-4.2.1-2.el5.art.x86_64.rpm Development files for International Components for Unicode
libicu42-doc-4.2.1-2.el5.art.x86_64.rpm Documentation for International Components for Unicode
libident-0.32-1.el5.art.x86_64.rpm New LibIdent C library
libident-devel-0.32-1.el5.art.x86_64.rpm Development files for libident
libident-tools-0.32-1.el5.art.x86_64.rpm A small daemon that can be used to test Ident servers
liblve-0.7.3-2.el5.art.x86_64.rpm LVE kernel module API library
liblve-devel-0.7.3-2.el5.art.x86_64.rpm LVE kernel module API library
liblve-devel-static-0.7.3-2.el5.art.x86_64.rpm LVE kernel module API library
Advertisement
Advertisement