lasi-1.0.6-1.el5.art.x86_64.rpm


Advertisement

Description

lasi - C++ library for creating Postscript documents

Property Value
Distribution CentOS 5
Repository Atomic x86_64
Package name lasi
Package version 1.0.6
Package release 1.el5.art
Package architecture x86_64
Package type rpm
Installed size 78.58 KB
Download size 35.38 KB
Official Mirror www6.atomicorp.com
LASi is a library written by Larry Siden  that provides a C++ stream output
interface ( with operator << ) for creating Postscript documents that can
contain characters from any of the scripts and symbol blocks supported in
Unicode  and by Owen Taylor's Pango layout engine. The library accomodates
right-to-left scripts such as Arabic and Hebrew as easily as left-to-right
scripts. Indic and Indic-derived Complex Text Layout (CTL) scripts, such as
Devanagari, Thai, Lao, and Tibetan are supported to the extent provided by
Pango and by the OpenType fonts installed on your system. All of this is
provided without need for any special configuration or layout calculation on
the programmer's part.
Although the capability to produce Unicode-based multilingual Postscript
documents exists in large Open Source application framework libraries such as
GTK+, QT, and KDE, LASi was designed for projects which require the ability
to produce Postscript independent of any one application framework.

Alternatives

Package Version Architecture Repository
lasi-1.0.6-1.sdl5.i386.rpm 1.0.6 i386 PUIAS Unsupported
lasi-1.0.6-1.sdl5.x86_64.rpm 1.0.6 x86_64 PUIAS Unsupported
lasi-1.0.6-1.el5.art.i386.rpm 1.0.6 i386 Atomic
lasi-1.0.6-1.el5.i386.rpm 1.0.6 i386 EPEL
lasi-1.0.6-1.el5.i386.rpm 1.0.6 i386 EPEL
lasi-1.0.6-1.el5.x86_64.rpm 1.0.6 x86_64 EPEL
lasi - - -

Requires

Name Value
/sbin/ldconfig -
libc.so.6(GLIBC_2.4)(64bit) -
libfreetype.so.6()(64bit) -
libgcc_s.so.1()(64bit) -
libgcc_s.so.1(GCC_3.0)(64bit) -
libglib-2.0.so.0()(64bit) -
libm.so.6()(64bit) -
libpangoft2-1.0.so.0()(64bit) -
libstdc++.so.6()(64bit) -
libstdc++.so.6(CXXABI_1.3)(64bit) -
libstdc++.so.6(GLIBCXX_3.4)(64bit) -
rtld(GNU_HASH) -

Provides

Name Value
lasi = 1.0.6-1.el5.art
libLASi.so.0()(64bit) -

Download

Type URL
Binary Package lasi-1.0.6-1.el5.art.x86_64.rpm
Source Package lasi-1.0.6-1.el5.art.src.rpm

Install Howto

  1. Download the latest atomic-release rpm from
    http://www6.atomicorp.com/channels/atomic/centos/5/x86_64/RPMS/
  2. Install atomic-release rpm:
    # rpm -Uvh atomic-release*rpm
  3. Install lasi rpm package:
    # yum install lasi

Files

Path
/usr/lib64/libLASi.so.0
/usr/lib64/libLASi.so.0.0.0
/usr/share/doc/lasi-1.0.6/AUTHORS
/usr/share/doc/lasi-1.0.6/COPYING
/usr/share/doc/lasi-1.0.6/ChangeLog
/usr/share/doc/lasi-1.0.6/README

Changelog

2006-08-29 - - Orion Poplawski <orion@cora.nwra.com> - 1.0.6-1
- Update to 1.0.6
- Remove pkg-config patch applied upstream
2006-05-08 - - Orion Poplawski <orion@cora.nwra.com> - 1.0.5-2
- Disable static libs
- Patch pc file to return -lLASi
2006-05-04 - - Orion Poplawski <orion@cora.nwra.com> - 1.0.5-1
- Update to 1.0.5
- Remove unneeded patches and autotools
- Move doc dir to -devel package
- Make -devel package require pango-devel, included in LASi.h

See Also

Package Description
lasi-devel-1.0.6-1.el5.art.x86_64.rpm Development headers and libraries for lasi
lcab-1.0b9-1.el5.art.x86_64.rpm MS cab-files creator
ldns-1.6.16-1.el5.art.x86_64.rpm Lowlevel DNS(SEC) library with API
ldns-devel-1.6.16-1.el5.art.x86_64.rpm Development package that includes the ldns header files
ldns-python-1.6.16-1.el5.art.x86_64.rpm Python extensions for ldns
libadns-1.4-3.el5.art.x86_64.rpm The GNU asynchronous DNS resolver library
libadns-devel-1.4-3.el5.art.x86_64.rpm Development tools for libadns
libadns-progs-1.4-3.el5.art.x86_64.rpm Related programs for libadns
libatomic_ops-devel-1.2-2.el5.art.x86_64.rpm Atomic memory update operations
libbsd-0.6.0-1.el5.art.x86_64.rpm Library providing BSD-compatible functions for portability
libbsd-ctor-static-0.6.0-1.el5.art.x86_64.rpm Development files for libbsd
libbsd-devel-0.6.0-1.el5.art.x86_64.rpm Development files for libbsd
libedit-3.0-2.20090923cvs.el5.art.i386.rpm The NetBSD Editline library
libedit-3.0-2.20090923cvs.el5.art.x86_64.rpm The NetBSD Editline library
libedit-devel-3.0-2.20090923cvs.el5.art.i386.rpm Development files for libedit
Advertisement
Advertisement